Created using
htm2chm 3.0

Download it NOW!


WMASTER.RU - Всё для web-мастера

www.wmaster.ru
Wmaster.ru

На главную

Введение в дизайн

СТАТЬИ

Хостинг

CODY REG][STER

DOCS

КАТАЛОГ ссылок

Коллекция шрифтов

DESIGN.STudio

Клуб Webмастеров

Рейтинг (top-100)
Скрипты

Секреты мастеров

Soft

Журнал Wmaster

Опросы

Ссылки web-мастеру

Электронные журналы

Обратная связь

Гостевая книга

ФоруМ

web-mastering
Азы языка HTML
Programming
HTML-редакторы
Apache
MySQL
XML
Flash
Photoshop
.htaccess
Всё для форумов
Clipart
3DSMax
SSI
CSS
Технология раскрутки
Авторское право
Кодовые таблицы
Важное

Windows

Links
Woweb.ru - портал для Веб-Мастера
SAD-Raven
NBSP.RU
PHP скрипты
CN-Software
MOROZOV.BIZ
Точное выделение

Обычно, чтобы получить точное выделение вокруг объекта на фотографиях людей, пользуются инструментами волшебная палочка или лассо.
Использовать волшебную палочку можно только если Вы будете играть долгое время с настройками, чтобы нормально ей воспользоваться(например, нужный объект находится в монотонном фоне).
Допустим, мы должны выделить яблоко из этого изображения и поместить его на белый фон.

Конечно вы не можете воспользоваться здесь волшебной палочкой. Придется воспользоваться инструментом лассо - края яблока очень гладкие, чтобы выделять с помощью лассо.. Вы можете сказать, что будете удерживать Alt и использовать метод выбора лассо указал-нажал. Что ж, это путь, которым Вы в любом случае получите более или менее треугольные края. А также, если Вы сделаете ошибку, Вы должны будете делать все с начала. В нашем примере, яблоко - небольшое но представляет собой некоторый очень сложный объект типа человеческого тела или волоса.
Лучший инструмент создания выделения в данном случае инструмент пути (Path tool).
Если Вы нажмете на него и удержите некоторое время, появится подменю с 5 другими иконками
Первый это фактически инструмент пути.
Второй это инструмент установки узлов (Используется для регулирования и перемещения узлов).
Третий используется для добавления узлов и естественно следующий номер для удаления узлов
Последний используется чтобы регулировать кривые. (мы воспользуемся этим позже)

Сначала мы сделаем черновое выделение вокруг яблока (просто выбирайте точку и ставьте ее с помощью инструмента лассо). Возьмите инструмент пути (один без + или -). Поставьте курсор в любое место на краю яблока и нажмите и отпустите кнопку мыши. Не двигайте мышь, пока кнопка нажата. Это может превратить узел в искривленный узел (нам это не скоро понадобится).
Затем продолжайте нажимать и отпускать кнопку, пока не сделаете выделение вокруг яблока (Решайте сами, как часто ставить точки, это зависит от кривизны объекта).
Теперь у вас есть более или менее треугольный путь по краю вокруг яблока. Вы можете взять узел инструментом установки и двигать указатель вокруг чтобы достичь более точное выделение. Я предлагаю изменить масштаб на 250-300%, чтобы увидеть фактический край лучше.
Вот и подошла сложная часть выделения. Возьмите инструмент установки кривых (последняя иконка в панели инструментов). Затем ОЧЕНЬ осторожно поставьте точку на край, который слишком сильно не совпадает с нужным и не отпуская кнопку мыши медленно перемещайте согласно направлению краев (Вы должны заставить края выделения лежать вокруг объекта).
Как только Вы все сделаете, сделайте путь выделением. Между прочим, имеющийся ПУТЬ вместо ВЫДЕЛЕНИЯ в файле тоже удобно, поскольку путь выделяет значительно меньше пространства чем дополнительное выделение (что актуально для канала).
Прежде всего идите в палитру путей. (Window>Show Paths). Затем два раза кликните на пути и переименуйте, если хотите сохранить его. Теперь нажмите на маленький треугольничек в верхнем правом углу окна палитры и выберите Make selection.... Используйте анти-эффект наложения (anti-aliasing) и настройте перо в зависимости от размера образа. В этом примере, который я использовал 0.5 пикселя.

Теперь Вы можете иметь это как слой (нажмите Ctrl-E) или просто залейте чем-нибудь область вокруг него (не забудьте инвертировать выделение для этого :-)

Назад

Партнеры Wmaster
srez.ru: Новости, уроки DreamWeaver, PhotoShop, HTML
Лучшее веб-мастеру
PIXELATE - Первый в рунете сайт о пиксельной графике! Уроки, галлерея, форум и многое другое!
Поиск по сайту
Объявления
Обмен ссылками
Наши баннеры
О проекте

Реклама
(понижение цен)

Об Авторе
Контакты new!
Архив рассылки
Продажа доменов
Запомнить эту страницу
Сделать стартовой
Хостинг
Хостинг Без Ограничений.
Рассылки от Wmaster.Ru
Wmaster.ru - всё для вебмастера.
Наша кнопка

Все желающие могут поставить нашу кнопочку к себе на сайт
Всё для веб-мастеров

Бочкарёв Антон
ICQ: 148780826
Hosted by Valuehost
© RUscripts.design 2003

© Wmaster Design Group 2001-2003. © Все права защищены. При перепечатке любого материала с сайта ссылка на http://www.wmaster.ru/ обязательна.
Для просмотра рекомендуется разрешение 1024*768, браузер Internet Explorer. Для более эффективного просмотра нажмите F11.