Created using
htm2chm 3.0

Download it NOW!


WMASTER.RU - Всё для web-мастера

www.wmaster.ru
Wmaster.ru

На главную

Введение в дизайн

СТАТЬИ

Хостинг

CODY REG][STER

DOCS

КАТАЛОГ ссылок

Коллекция шрифтов

DESIGN.STudio

Клуб Webмастеров

Рейтинг (top-100)
Скрипты

Секреты мастеров

Soft

Журнал Wmaster

Опросы

Ссылки web-мастеру

Электронные журналы

Обратная связь

Гостевая книга

ФоруМ

web-mastering
Азы языка HTML
Programming
HTML-редакторы
Apache
MySQL
XML
Flash
Photoshop
.htaccess
Всё для форумов
Clipart
3DSMax
SSI
CSS
Технология раскрутки
Авторское право
Кодовые таблицы
Важное

Windows

Links
Woweb.ru - портал для Веб-Мастера
SAD-Raven
NBSP.RU
PHP скрипты
CN-Software
MOROZOV.BIZ
Приминение маски

Предисловие
При монтаже нескольких изображений Вы иногда сталкиваетесь с проблемой выделения. В случае, если объект имеет простые и хорошо-контрастные грани, Вы можете использовать инструмент волшебной палочки или что-то вроде этого. Если же фон не контрастный, вы бы были должны создать выбор, используя инструмент лассо или что является наиболее обычным инструмент пути. Но имеются некоторые случаи, где уровень детализации слишком высок и даже если Вы - очень осторожный человек и имеете большое количество терпения, это может быть также сложной задачей. Хотите пример? Право, это - волосы. Если Вы берете любой журнал и более близко его просматриваете, Вы можете заметить, что иногда волосы на фотографиях или соединениях хорошо детализированы, но иногда нет. Эта методика поможет Вам изучать, как делать маску для волос или любых других сложных объектов на профессиональном уровне..
Каналы
Так, что является маской? Маска - фактически информационный канал, который указывает, какие пиксели должны быть включены в выбор. В Photoshop Вы можете только открыть палитру канала (Window>Show Channels) И см. каналы файла. Каждый канал представляет маску. Да, даже если каналы Вы видите как RGB, или CMYK - те - все маски. В случае RGB, Красный канал представляет все красное в изображении. Здесь более темная точка соответствует более красному цвету в RGB канале.
Создание маски фактически означает создание канала, который представил бы нашу маску. Для большей ясности по этой теме имеются некоторые примеры с масками.

Это - простое изображение, которое мы будем использовать в нашем примере. Я создал новый Канал (Channel#4) и нарисовал там 2 белых прямоугольника.
Да, это - Channel #4, как можно увидеть в Палитре Каналов
Теперь, чтобы загрузить канал в главное изображение я должен сначала переключиться на канал RGB и затем идти в Select>Load Selection.. и выбрать channel #4.
Загруженная маска - является выделением.

В случае, если Вы имеете изображение в JPEG формате, Вы можете также заметить что один из каналов (обычно синий) выглядит размазанным и поврежденным. Фактически так работает JPEG компрессия - она сжимает один из каналов больше чем другой, но визуально в RGB Вы не замечаете, что это не тот синий цвет, который существует в природе.
Итак, вернемся к нашему изображению. Нам нужно изображение и соответствующая маска, которая работала бы как маска прозрачности.

Режимы цвета
Я рекомендую переключить к CMYK перед созданием маски волос, используя методику, описанную ниже. Даже больше, я буду описывать все применительно CMYK изображения. CMYK изображение дает более точную информацию относительно цвета, и мы будем это использовать.
Маски
Как упомянуто прежде, чем мы должны создать маску. Давайте выбирать наиболее сложную часть процесса выбора маски и пробовать решить проблему. Имеется готовое изображение фотографии, с которым мы собираемся работать. Цель состоит в том, чтобы устранить фон. В случае, если Вы использовали бы инструмент пути (Path), чтобы выбрать волосы, это отнимет массу времени, чтобы получить более или менее точный выбор.

Эта методика использует каналы цветов, чтобы создать маску. Конвертируйте ваше изображение в CMYK, если Вы это еще не сделали. (Image>Mode>CMYK).
Давайте посмотрим на каналы в этом изображении.

Поскольку Вы можете видеть большая часть контрастного канала черная. Это - то, что мы собираемся использовать как наш опытный образец маски. Прежде всего, сделайте копию Черного канала, перемещая его к иконке Нового Канала.
Переключитесь в В канал #5 (channel #5).
Давайте начнем создавать нашу маску. Первая вещь, которую Вы должны сделать - корректировать черные уровни, чтобы увеличить контраст. Image>Adjust>Levels...

Перетащите средний указатель, как показано на изображении, в право. Это делает Channel #5 более контрастным.
Следующий шаг очень важен. Вы будете должны рисовать путь, но Вам не надо будет делать маску волос. Вы фактически уже сделали маску волос (область волос очень контрастна). Так, точно рисуйте путь вокруг требуемой области. Вы можете видеть, как приблизительно это должно выглядеть. Не касайтесь волос.

Следующая вещь, которую Вы должны сделать, состоит в том, чтобы использовать Волшебную Палочку (Magic Wand), чтобы выбрать черную область внутри нашей маски. Только возмите Волшебную Палочку и щелкните где-нибудь в середине этого изображения. Вы получите выделение. Чтобы получить большую точность изображения, нужно чувствительность волшебной палочки конфигурировать на более точное выделение, получаемое Вами.
Делайте Select>Inverse и залейте белым. Инвертируйте все изображение (Image> Map>Invert).

Это - маска, в которой мы нуждались. Теперь, Вы можете только переключиться на канал CMYK, Select> Load Selection>#5, Select>Invert И заполнить белым или в зависимости от того, что Вы хотите. Или Вы можете не инвертировать маску и копировать ее в буфер обмена, чтобы вставить туда другое изображение. Все зависит от Вас и вашего воображения.

Назад

Партнеры Wmaster
srez.ru: Новости, уроки DreamWeaver, PhotoShop, HTML
Лучшее веб-мастеру
PIXELATE - Первый в рунете сайт о пиксельной графике! Уроки, галлерея, форум и многое другое!
Поиск по сайту
Объявления
Обмен ссылками
Наши баннеры
О проекте

Реклама
(понижение цен)

Об Авторе
Контакты new!
Архив рассылки
Продажа доменов
Запомнить эту страницу
Сделать стартовой
Хостинг
Хостинг Без Ограничений.
Рассылки от Wmaster.Ru
Wmaster.ru - всё для вебмастера.
Наша кнопка

Все желающие могут поставить нашу кнопочку к себе на сайт
Всё для веб-мастеров

Бочкарёв Антон
ICQ: 148780826
Hosted by Valuehost
© RUscripts.design 2003

© Wmaster Design Group 2001-2003. © Все права защищены. При перепечатке любого материала с сайта ссылка на http://www.wmaster.ru/ обязательна.
Для просмотра рекомендуется разрешение 1024*768, браузер Internet Explorer. Для более эффективного просмотра нажмите F11.