Created using
htm2chm 3.0

Download it NOW!


WMASTER.RU - Всё для web-мастера

www.wmaster.ru
Wmaster.ru

На главную

Введение в дизайн

СТАТЬИ

Хостинг

CODY REG][STER

DOCS

КАТАЛОГ ссылок

Коллекция шрифтов

DESIGN.STudio

Клуб Webмастеров

Рейтинг (top-100)
Скрипты

Секреты мастеров

Soft

Журнал Wmaster

Опросы

Ссылки web-мастеру

Электронные журналы

Обратная связь

Гостевая книга

ФоруМ

web-mastering
Азы языка HTML
Programming
HTML-редакторы
Apache
MySQL
XML
Flash
Photoshop
.htaccess
Всё для форумов
Clipart
3DSMax
SSI
CSS
Технология раскрутки
Авторское право
Кодовые таблицы
Важное

Windows

Links
Woweb.ru - портал для Веб-Мастера
SAD-Raven
NBSP.RU
PHP скрипты
CN-Software
MOROZOV.BIZ
1.6. Формы

Интерактивные формы позволяют читателям Web-страниц легко общаться с их владельцами. Благодаря простоте использования тага <mailto:> и форм стал возможен двусторонний диалог между владельцами Web-узлов и их читателями. Это открывает для Web-навигаторов увлекательные перспективы и коммерческие возможности. К сожалению, многие старые броузеры не поддерживают таг <mailto:>.

Как сделать так, чтобы ваша форма хорошо смотрелась

Один из способов свести все трудности к минимуму состоит в том, чтобы разместить области ввода и выпадающие меню в левой части страницы, а весь сопроводительный текст - справа. Поскольку ширину областей ввода можно задать с помощыо атрибута SIZЕ=, вы по крайней мере выровняете строки слева, а текст справа будет невыровненным - как в большинстве документов. Такая форма выглядит несколько аккуратнее. Не забудьте оставить промежуток между текстом и областью ввода формы. Другой несколько более сложный способ - разместить элементы формы в ячейки таблицы. Это позволяет разместить сопроводительный текст слева, а области ввода справа. Это показано в примере.

Пример 1.26

    <HTML>
    <HEAD>
    <TITLE>Коментарии</TITLE>
    </HEAD>
    <BODY>
    <H1>Коментарии</H1>
    <BR>Пожалуйста сообщите нам, что вы думаете
     о нашем web сайте, компании,
    продукции, или услугах. Если вы сообщите нам
    свою контактную информацию,
    у нас будет возможность связаться с вами
    и ответить на ваши вопросы.</p>
    <FORM METHOD="POST" action="mailto:
    yourname@your.email.address">
    <H3>Контактная информация</H3>
    <TABLE BORDER="0">
    <TR>
    <TD ALIGN="right"><em>Имя</em></td>
    <TD><input type="text" size="35" name="Name"></td>
    </TR>
    <TR>
    <TD ALIGN="right"><em>Тема</em></td>
    <TD><input type="text" size="35" name="Title"></td>
    </TR>
    <TR>
    <TD ALIGN="right"><em>Компания</em></td>
    <TD><input type="text" size="35"
     name="Company"></td>
    </TR>
    <TR>
    <TD ALIGN ="right"><em>Адрес</em></td>
    <TD><input type="text" size="35"
    name="Address"></td>
    </TR>
    <TR>
    <TD ALIGN ="right"><em>Телефон</em></td>
    <TD><input type="text" size="35"
    name="Telephone"></td>
    </TR>
    <TR>
    <TD ALIGN ="right"><em>Факс</em></td>
    <TD><input type="text" size="35" name="FAX"></td>
    </TR>
    <TR>
    <TD ALIGN ="right"><em>E-mail</em></td>
    <TD><input type="text" size="35" name="Email"></td>
    </TR>
    </TABLE>
    <p>
    <input type="reset" value="Очистить форму"> </p>
    </FORM>
    </BODY>
    </HTML>

Как заставить формы работать

Возможно, это именно тот раздел, которого вы ждете - как сделать так, чтобы формы отсылали на сервер введенные данные. На самом деле заставить форму пересылать данные довольно просто. Главная проблема - понять, куда их пересылать. Формально вы просто пишете в таге <FORM> атрибут АСТION= и задаете ссылку на URL программы, которая может обработать входные данные и сделать с ними что-нибудь полезное.

Партнеры Wmaster
srez.ru: Новости, уроки DreamWeaver, PhotoShop, HTML
Лучшее веб-мастеру
PIXELATE - Первый в рунете сайт о пиксельной графике! Уроки, галлерея, форум и многое другое!
Поиск по сайту
Объявления
Обмен ссылками
Наши баннеры
О проекте

Реклама
(понижение цен)

Об Авторе
Контакты new!
Архив рассылки
Продажа доменов
Запомнить эту страницу
Сделать стартовой
Хостинг
Хостинг Без Ограничений.
Рассылки от Wmaster.Ru
Wmaster.ru - всё для вебмастера.
Наша кнопка

Все желающие могут поставить нашу кнопочку к себе на сайт
Всё для веб-мастеров

Бочкарёв Антон
ICQ: 148780826
Hosted by Valuehost
© RUscripts.design 2003

© Wmaster Design Group 2001-2003. © Все права защищены. При перепечатке любого материала с сайта ссылка на http://www.wmaster.ru/ обязательна.
Для просмотра рекомендуется разрешение 1024*768, браузер Internet Explorer. Для более эффективного просмотра нажмите F11.