Created using
htm2chm 3.0

Download it NOW!


WMASTER.RU - Всё для web-мастера

www.wmaster.ru
Wmaster.ru

На главную

Введение в дизайн

СТАТЬИ

Хостинг

CODY REG][STER

DOCS

КАТАЛОГ ссылок

Коллекция шрифтов

DESIGN.STudio

Клуб Webмастеров

Рейтинг (top-100)
Скрипты

Секреты мастеров

Soft

Журнал Wmaster

Опросы

Ссылки web-мастеру

Электронные журналы

Обратная связь

Гостевая книга

ФоруМ

web-mastering
Азы языка HTML
Programming
HTML-редакторы
Apache
MySQL
XML
Flash
Photoshop
.htaccess
Всё для форумов
Clipart
3DSMax
SSI
CSS
Технология раскрутки
Авторское право
Кодовые таблицы
Важное

Windows

Links
Woweb.ru - портал для Веб-Мастера
SAD-Raven
NBSP.RU
PHP скрипты
CN-Software
MOROZOV.BIZ
1.4. Использование таблиц в дизайне страницы

Приятное свойство таблиц состоит в том, что если вы захотите, то можете сделать их границы невидимыми. Это позволяет с помощью тага <ТАВLЕ> красиво размещать на странице текст и графику. До сих пор таг <ТАВLЕ> остается единственным мощным средством форматирования в HTML. Дизайнеры Web-страниц сейчас обладают практически такой же свободой использования <пустого пространства>, что и создатели печатных страниц. Таблицы в большей мере, чем что-либо другое, помогают отойти от иерархического размещения текста на Web-страницах.

Если броузер вообще поддерживает таблицы, он обычно правильно отображает наиболее интересные эффекты, полученные с помощью таблиц.

Пример 1.20

    <HTML>
    <BODY>
    <CENTER>
    <TABLE CELLPADDING=10 CELLSPACING=0 BORDER=16>
    <TR>
    <TD ALIGN=CENTER>
    <H1>ПЕРФОРАТОР</H1>
    <H3>Только сегодня!</H3>
    <TABLE BORDER WIDTH=100%>
    <TR><TD ALIGN=CENTER><I>Почти бесплатно!</I></TD>
    </TR>
    </TABLE>
    </TD>
    </TR >
    </TABLE>
    </CENTER >
    </BODY>
    </HTML>

Ведущие броузеры, позволяют отображать некоторые цвета. Есть несколько способов раскрасить таблицу, в основном они зависят от используемого броузера.

Цветные границы в Netscape Navigator

Вы не только можете окружить таблицу красивой рамкой, но еще и задать для нее цвет, отличный от цветов текста и фона. Создайте простой серый GIF (или любой GIF, который вы хотели бы иметь в качестве фона) и определите его в таге <ВODY> как фон страницы. Затем задайте цвет фона страницы. В результате ваш таг <ВОDY> будет выглядеть примерно так:

    <BODY ВАСКGROUND="сооlbg.gif" ВGCOLOR=" # FF0000">

Вы создали двойной фон - GIF и заданный цвет. В результате фоновый цвет будет виден на всех границах таблиц и горизонтальных линиях (<НR>). Вне зависимости от того, является ли ваш фоновый GIF серым или нет, цветные линии и границы таблиц будут заметно выделяться. Если фоновый GIF не слишком сложно устроен, время загрузки страницы лишь немного возрастет. На приведенном ниже примере показано какие, широкие возможности дает использование цвета в HTML и в частности в таблицах.

Пример 1.21

    <HTML>
    <BODY BACKGROUND="bgr.gif"  BGCOLOR="YELLOW" >
    <CENTER>
    <TABLE BORDER=3 CELLPADDING=20>
    <CAPTION ALIGN=TOP><H2>Как просверлить бетонную
     стену</H2></CAPTION>
    <TR>
    <TD BGCOLOR=GRAY>
    <TABLE CELLPADDING=10 CELLSPACING=0 BORDER=16>
    <TD BGCOLOR=RED ALIGN=CENTER>
    <H1>ПЕРФОРАТОР</H1>
    <H3>Только сегодня!</H3>
    <TABLE BORDER WIDTH=100%>
    <TR>
    <TD BGCOLOR=AQUA ALIGN=CENTER>
    <I>Почти бесплатно!</I></TD>
    </TR>
    </TABLE>
    </TABLE>
    <TD WIDTH=50% BGCOLOR=BROWN ALIGN=CENTER>
    <IMG SRC="perfor1.gif" WIDTH=200 HEIGHT=150>
    </TD>
    </TR>
    <TR>
    <TD BGCOLOR=PINK>
    <FONT SIZE=6 COLOR=BLUE>От 6 до 20 мм</FONT>
    </TD>
    <TD  BGCOLOR=BLUE>
    <FONT SIZE=6 COLOR=PINK>Просверлим все</FONT>
    </TD>
    </TR>
    </TABLE>
    </CENTER >
    </BODY>
    </HTML>
Партнеры Wmaster
srez.ru: Новости, уроки DreamWeaver, PhotoShop, HTML
Лучшее веб-мастеру
PIXELATE - Первый в рунете сайт о пиксельной графике! Уроки, галлерея, форум и многое другое!
Поиск по сайту
Объявления
Обмен ссылками
Наши баннеры
О проекте

Реклама
(понижение цен)

Об Авторе
Контакты new!
Архив рассылки
Продажа доменов
Запомнить эту страницу
Сделать стартовой
Хостинг
Хостинг Без Ограничений.
Рассылки от Wmaster.Ru
Wmaster.ru - всё для вебмастера.
Наша кнопка

Все желающие могут поставить нашу кнопочку к себе на сайт
Всё для веб-мастеров

Бочкарёв Антон
ICQ: 148780826
Hosted by Valuehost
© RUscripts.design 2003

© Wmaster Design Group 2001-2003. © Все права защищены. При перепечатке любого материала с сайта ссылка на http://www.wmaster.ru/ обязательна.
Для просмотра рекомендуется разрешение 1024*768, браузер Internet Explorer. Для более эффективного просмотра нажмите F11.