Created using
htm2chm 3.0

Download it NOW!


Фрейм или не фрейм.

 Sorry there are not a frame support in your browser.


Home e-mail

Link 1
Link 2
Link 3
Link 4


Оно и понятно, ведь баннер рядышком с полосой прокрутки это кликтивно.


Рассмотрим очень спорную тему

То, что вы сейчас видите - пример типичной структуры для корпоративной страницы. Да, вроде все соблюдено: левое поле для удобства чтения, заголовок прекрасно вписывается слева, баннер хорошо расположен около прокрутки - не нужно мышью бегать по экрану чтобы нажать, стргий бэкграунд, - словом все как нужно.
Меня часто спрашивают делать с фреймом или без него. Ответ, я надеюсь, вы найдете на этй странице.
Если вы успели заметить, страница сделна при помощи фреймов, и не случайно. Согласитесь, что это проще, чем строить таблицу, ведь в таблице позиционировать объекты ох как трудно. Не нужен <blockquote> для создания полей и других ухищрений в виде прозрачных рисунков 1х1 пиксел для позиционирования. Но, - скажете вы, - ведь фрейм имеет столько недостатков и почти никаких достоинств. Я попытаюсь опровергнуть ваши убеждения и признать, что фрейм придумали умные люди не зря.

Начнем с достоинств.

Первое - удобство позиционирования.

Вторе - Позволяет загружать отдельные документы, при этом оставлять навигацию, заголовки и т.д., что экономит посетителю время загрузки.

Третье - Позволяет посетителю прокручивать один фрейм, при этом остальные фреймы будут видимы.

Четвертое - Дает возможность дизйнеру контролировать величину фреймов, тоесть например на этой странице левый и правый фрейм фиксированного размера.

Пятое - Не маловажный факт, - фрейм является дочерним объектом от объекта window, Тоесть, если создать функции или переменные на JavaScript в головном документе, то из любого фрейма можно будет обратиться к функции или переменной как к родительскому объекту через parent.function()OrVariable. Почему это важно? А что если вы одну и ту же функцию вешаете во многие документы, а что если вам нужно, чтобы сохранялись значения переменных при навигации по сайту? Убедил? Что? Некоторые брузеры не поддерживают фреймы? В таком случае они не должны поддерживать JavaScript. Вы же не хотите, чтобы левой бродилкой просматривали ваш сайт, ведь они не увидят весь ваш замысел, всю его дизайнерскую мощь. Тогда ему нечего у вас в гостях делать. По моим наблюдениям таких только 0,7 из тысячи посетителей - специально проверял, ставил счетчик между тегами <noframe>. . . </noframe>. Если вам очень важны эти 0,07% - делайте без фреймов.

Недостатки:

Первый недостаток, который ограничивает применение фреймов, - это то, что "Многие поисковые машины плохо сканируют фреймосодержащие документы". И это говорят Русские, да к тому же еще и Уважаемые и Авторитетные люди. А если завтра вам скажут, что нужно по пятницам в колодцы прыгать? Утверждение, что касается поисковых машин необосновано. Например что вам мешает в файле index.htm оформить ссылки на буквально все страницы вашего сайта еще до описания фрейма, да, можно поставить кучу например графических 1х1 пиксель ссылок для пущей убедительности поисковым индексам. Желательно продублировать ссылки и между тегами < noframe>. . . </noframe>. То же самое можно делать и на других страницах сайта, а также предусмотреть текстовую навигацию обычно в конце страницы. С такой структурой поисковой машине хватит работы. Убедил? Вопрос снимается.

Второй - не все браузеры поддерживают фреймы. Ну конечно, у вас нет гордости, пусть смотрят ваш сайт досовскими браузерами, пусть видят как неприглядно все офрмлено. Ваши старания с динамичностью объектов напрасны, этот перец из колхоза на ХТ-шке прикатил, у него момед 2400 и все такое, - бесспорно, очень "Ценный" посетитель. Конечно, обрботка с помощью тега <noframe> не помешет, ведь обычно ошибка не вываливается на экран, когда браузер фреймы не поддерживает (нетскапом проверял, другие не знаю). Да не осталось таких браузеров. Можно изобразить конечно с Нетскейпом, модули поубирать, те что с фреймами работают, а зачем? Принципы? Нечего тогда в НЕТЕ шариться, с принципами нужно собак дразнить. Имеет место, что некоторые браузеры не хотят понимать атрибут "border=0", но таких меньшинство. Тоже снимаю вопрос.

Третий - должен признать, - это недостаток. Если посетитель захочет оставить себе в избранное какую-либо страницу вашего сайта, он непременно сохранит ссылку на головной документ, а уже потом с помощью навигации найдет нужную стрницу. Ну если конечно не догадается нажать правую кнопку мыши в поле нужного документа. Также не отображается и URL просматриваемой страницы в адресной строке браузера. Можно решить такой вопрос приблизительно так: написать небольшой скрипт, где будет предлагаться поместить страницу в "избранное", а на такой странице сделать предложение со ссылкой для загрузки фрейма. С навигцией не должно быть проблем. Навигация - самое главное во фреймосодержащих документах.

В заключение можно только добавить: Фрейм или Не фрейм - решать вам. Посмотрите несколько зарубежных сайтов, и вы убедитесь, что некоторые даже очень серьезные проекты оформлены фреймами.