Created using
htm2chm 3.0

Download it NOW!


От замысла к воплощению ч1. Статья раздела Веб-дизайн. WDstudio.

От замысла к воплощению ч.2

Вот мы и пришли к тому, что нужно выработать замысел, тоесть сам дизайн будущего сайта. Прежде, чем начать делать, я не говорю про полновесный сайт, только одну страницу, - у вас должно быть все продумано до мелочей. По принципу: "Добавим потом", "Если что, - изменим навигацию", "Появится новый проект, - организуем портал" - это самая большая ошибка многих, будем называть дизайнеров. Нужна идея, замысел. Не секрет в том, что сайт, даже значительный по объему можно сотворить за неделю, но а если все хорошо продумано, заложен основной скелет - и того меньше. Очень много времени уходит на сам замысел. Некоторым дизайнерам иногда приходят самые лучшие идеи вне работы над сайтом, тогда, чтобы не забыть это "видение" они быстренько делают зарисовки или в памяти появляется картина будущего сайта.
Скажем, существует две категории людей: одни люди живут прозой, другие желанием творить. Так вот, художник например будет особенно замечать сочетания красок, теней, форм. Фотограф будет на это все смотреть с точки зрения фотоэкспозиции, где свет является как "другом" так и "врагом". Музыкант, увидев какую-либо впечатляющую картину прокрутит в голове новую мелодию. Чаще всего источником вдохновения служат какие-либо природные объекты и их сочетание. Мы привыкли, что небо голубое, снег и облака белые, а листья и трава зеленые. Измени что-либо в этом балансе красок и все станет непривычным. А экспрессионизм, скажете вы? Хорошо, если вы понимаете то, что вы изобразили, если эти изменения вызваны вашим настроением и только вашим, это совсем не значит что все другие видят или слышат то, что видите или слышите вы.
Откуда же брать идеи дизайнеру? Как повелось с начала компьютерной эры, программист, а дизайнер это программист, но с более широким взглядом на окружающее, так вот, программист в первую очередь должен быть тем для кого он пишет программу: для бухгалтерии - бухгалтером, для юриста - юристом. Так было и так будет. В таком случае Web-дизайнер это программист с художественным вкусом. Также как мы часто не можем говорить: это плохой художник, а это хороший справедливо и для дизайнеров. Вот только программист, отлично ориентирующийся в современных технологиях построения Web, не всегда может быть дизайнером, также как профессиональный маляр не всегда может быть художником. Итак, мы подвели итог, окончательно оценили себя и твердо решили, что если мы не дизайнеры, то способные ученики в этой области. А иначе тогда зачем вы пришли на этот сайт?
Дизайнером вы станете, вероятно тогда, когда будете замечать вывески на киосках, магазинах, будете рассматривать упаковки каких-либо вещей, всматриваться в так называемую, надоевшую всем до чертиков, "рекламу" по ящику, всматриваться в какие-либо некогда привычные вещи и замечать то, что не все замечают, и т.д. Но вот у вас есть конкретная задача, конкретная тематика будущего сайта. Вы ломаете голову, каков же нужен дизайн, на что делать основной упор: скорость загрузки или динамичность навигации? Что ж, для начала нужно определиться в тематике. Если на сайте предполагается ценная текстовая информация, например сборник рефератов, MP3-коллекция, - здесь посетитель особенно не будет рассматривать все ваши навороты. Но вот если, например, демонстрирующий DHTML и приемы его применения, - сам Бог велел применять то, о чем пишешь. Ну и наверное если ваш сайт будет на, скажем, кулинарную тематику вы же не будете использовать изображения автомобилей или компьютеров. Цветовая гамма, - самая больная тема. Но и здесь есть подсказка: представьте тополиный пух или пух одуванчиков другого цвета, то есть не цвета облаков - согласитесь, насколько безобразная картина получится. Не нужно пренебрегать тем, что вы видите вокруг себя, - природные краски привычны и потому совершенны.
Где же все-таки брать идеи для замысла? А нигде. Если бы это было так просто, то дизайнером мог бы стать буквально каждый. Идеи обычно приходят стихийно, на то это и идеи. А вот чтобы эти идеи приходили и нужен замысел, нужен расклад, который послужит фильтром для множества вариантов решения задачи. На примере: Вы идете по улице и видите вывеску. Оцениваете ее критически и замечаете кучу недостатков, это может и неудачное цветовое решение, неправильны формы, где-то угол чересчур прямой, какие-то объекты не гармонируют. Включаете свою мысль и дорабатываете это до неузнаваемости. Далее, ведь у вас имеется фильтр-замысел: перерисовываете все под свою задачу. Что у вас получилось? Аааа, что-то смутно напоминающее начальный объект, в данном случае вывеска. А ведь это может быть и упаковка чего-либо. Нет, я совсем не призываю копировать чужие идеи, - это по меньшей мере аморально, использовать /не копировать/ замысел - совсем другое. Например, неужели бы кто-то из дизайнеров электронной аппаратуры с ЖК индикаторами предъявил претензию о том, что я попросту говоря спер дизайн разработанный где-то в 70-х годах LCD-индикатора. Да, я использовал подобие цвета и изображения символов, но не крал дизайна. По аналогии, если кто-либо разработал дизайн записной книжки и использовал при этом бумагу разлинованную в клеточку а не в "кружок".
Ну вот вроде и все мысли на этот счет. Теперь об этой странице: ФРЕЙМ - ненавистный по некоторым причинам дизайнерам, заметьте, не пользователям а дизайнерам или теми кто ими себя считает. Ну что поделать? Пойдем навстречу пользователю, пусть он меньше ждет загрузки "очередной таблицы". Графикой перегрузок нет: ~20 кб - общий размер заголовочной части. Использовал имитацию ЖКИ. Фрейм по горизонтали фиксирован и не имеет скроллинга, поэтому навигация смещена влево. В правой части анимационная мишура, которая несколько конкретизирует тему всего сайта. При минимизации окна анимация уходит за пределы экрана и ее не видно. Но так, как это только, как я выразился ранее, "мишура" - она не так важна во всей композиции. Применена динамическая навигация. Сайт, как и в предыдущей части предположительно для статистической организации. Навигация в верхнем фрейме, что часто нежелательно связана с тем, что информация на основной странице предположительно потребует всю ширину экрана. Вообще это только вариант страницы и не более, например для конкретной задачи нужна доработка навигации и других элементов, включая расположение, или отказ от фрейма и перевод в традиционный табличный вид. Вот в общем и все об этом. Вы, вероятно оцените это со своей точки зрения, но это и естественно, ведь Web - сфера, где не может быть однозначных мнений.

WDstudio © 2000г.