Created using
htm2chm 3.0

Download it NOW!


Что такое хорошо и что такое плохо. Статья раздела Веб-дизайн. WDstudio.

это демонстрационная страница

Ссылка 1
Ссылка 2
Ссылка 3
Ссылка 4
Ссылка 5
Ссылка 6
Ссылка 7
Ссылка 1
Ссылка 2
Ссылка 3
Ссылка 4
Ссылка 5
Ссылка 6
Ссылка 7

Крошка сын к оцу пришел
И сказала кроха:
Сайт табличный - хорошо
Фреймы - это плохо

Только вот я не буду так категорично подходить к этому вопросу. Часто можно увидеть неоправданные высказывания касательно фреймов. Иногда даже регистрируют в каталогах с пометкой "Свободно от фреймов". Но разговор в общем не об этом, а вернее не совсем об этом. Что приемлемо и желательно в Web-дизайне вопрос спорный и не мне об этом судить, но вот что плохо... Хотелось бы показать насколько нелепы, а иногда и вредны бывают некоторые элементы на множестве страниц. Итак:

  • Замена строки статуса. Пользователь чаще всего смотрит на эту строку тогда, когда не уверен полностью ли загружена страница, или еще грузятся какие-нибудь компоненты. Вы там помещаете "бегущую строку" - это что? Доказательство крутизны? Или места на странице не хватило? Не трогайте эту строку, она не ваша, а пользователя!

  • Alert, Confirm, Prompt . . . Видели ли вы сайт, где предлагается с интервалом в 2-3 минуты добавить сайт в избранное? Я видел, не буду называть URL, надеюсь владелец того сайта увидит когда-нибудь эту статью. Вот например, для того, чтобы поместить имя посетителя ему же в куки, а затем при повторном посещении сайта называть посетителя уже по имени, выскакивает окно с предложением ввести имя: - хорошо? Не считаю что это создаст для пользователя оптимистическое настроение. Пользователь просто случайно проходил мимо, он откинулся в кресле, правая рука с мышью вытянута, в левой руке бутылка пива, а клавиатура в недосягаемости, и ему вовсе не хочется тянуться к клаве. Если уж и хотите удивить пользователя, пишите в куки метку без опроса имени, а затем сообщите тогда уж, что он побывал уже здесь.

  • Оконный бунт Самое мерзкое, что можно только придумать. Напоминает войну с тараканами, где нужно вовремя давить на крестики в правом верхнем углу "бунтующих" окон. Скоро появится новая "ФОБИЯ" - боязнь окон. Вы что, серьезно думаете, что пользователь будет ждать загрузки в невесть-откуда появившееся окно? На многих сайтах можно увидеть предупреждение, что ссылка откроется в новом окне. И это только ссылка, причем некоторые пользователи специально при помощи правой клавиши мыши открывают ссылку в новом окне, чтобы не возвращаться к предыдущей странице. Поэтому довольно часто применяют атрибут "target=_top". Но вот рекламное окно? Разделываются как с врагами и больше на этот сайт ни кликом.

  • Правая клавиша не работает. Хотите узнать мое мнение? Я такие сайты заношу в черный список. Для кого они делают публикации в Internet? Понял, для накрутки баннерных показов. Чайник и так не разберется в сложных JavaScript-наворотах, а тот кто разберется, - разберется как эту помеху обойти. Скорее никто разбираться в этом не будет, а просто не будет больше там появляться.

  • Эту страницу лучше просматривать . . . Пользователь сам знает чем и как просматривать. Лучше адаптируйте на оба популярных браузера. В последнее время, когда Linux получил большое распространение, казалось бы и Netscape увеличит долю в Internet. Вот только этого не происходит. Почему? Представьте, вы ищите очень нужную вам информацию, находите в поисковой системе URL, кликаете на ссылку, и вот на тебе . . . Дело в том, что этот корпоративный сайт делали непрофессионалы за небольшую цену - подобных "студий" сейчас множество, - обычно группа студентов. Забыли закрыть какой-либо тег или не знали о существовании тега <form>, ошибка в JavaScript-программе, да мало ли... А проверяли только в IE и страница совершенно не отображается в Netscape. Поэтому большинство пользуется IE так, как этот браузер менее критичен к ошибкам. "Страницу лучше просматривать в режиме 800х600". Хорошо, у меня монитор 21', как же мне быть? Вроде не слепой смотреть на буквы размером с 5 рублей (кто не видел 5 рублей - 25 центов), да и на качество графики повлияет. Извините, будет гораздо круче, если вы адаптируете страницу на режимы 800х600 и 1024х768, проверите предварительно режим пользователя и представите нужный вариант.

  • Вы зашли с . . . С какого IP - адреса я зашел, какой сегодня день, какая у меня операционная система, видеорежим, тип браузера и т.д. Пользователю это нужно? Если место свободное на странице девать некуда разместите анекдот, - полезнее будет. Если пользователь за чужим компьютером, то скорее он может не догадываться какой у него процессор, тип BIOS, производитель HD, и то, если уж слишком нужно и без вас узнает.

  • Окно открывается в полноэкранном режиме. Напрашиваются строки из стиха: (Ефим Шифрин читал, если не ошибаюсь) "Если птице отрезать руки ..." Вы что, действительно думаете что пользователь будет "сидеть"? В смысле сидеть без привычной панели инструментов окна. Скорее он постарается закрыть такое окно.

  • Ждите, грузится Flash... А если нет времени ждать? Предоставьте пользователю выбор, чтобы он мог пропустить загрузку сотен килобайтов.

Можно сделать такой вывод: современные Internet-технологии дают достаточно мощные средства для создания динамичных Web-страниц, так давайте применять их разумно.

WDstudio © 2000г.