Created using
htm2chm 3.0

Download it NOW!


WDstudio. Все для Веб. Обзоры по Дизайну в Web. В помощь Вебмастеру -->>Что нового в HTML 4.0

Клуб друзей

Что нового в HTML 4.0

В этом разделе описываются основные изменения и дополнения языка HTML 4.0 в сравнении HTML 3.2. Полное описание и спецификацию этого языка можно скачать непосредственно с World Wide Web Consortium (W3C) если вы, конечно, хорошо ориентируетесь в английском языке.

Начнем рассмотрение с тэгов, которые в целом описывают документ HTML
Тэг, проверяющий синтаксис HTML документов для броузеров версии ниже 4.0 должен содержать информацию:

<!doctype html public "-//w3c//dtd html 4.0 //en">
Практически у всех ТЭГов могут присутствовать один или несколько атрибутов. Основные 6 атрибутов: ID, DIR, TITLE, LANG, CLASS, STYLE.
Атрибут ID задает уникальное имя элемента HTML документа. Обычно используется совместно с таблицами стилей или для доступа к элементу из скриптовой программы.
Атрибут DIR может иметь 2 значения - LTR и RTL, указывающие на то, как будет отображаться текст слева направо или справа на лево. Атрибут TITLE задает необязательный текст tooltip. При попадании указателя мыши на элемент появляется подсказка:
<h3 title="текст для пояснения данного заголовка">
Это пример заголовка текста. Подведите указатель сюда.
</h3>

Это пример заголовка текста. Подведите указатель сюда.

Атрибут LANG задает язык для данного элемента.
Атрибут STYLE используется для непосредственного указания стиля элемента.

Тэг <BODY>
В HTML4.0 атрибуты: BACKGROUND, BGCOLOR, ALINK, LINK, VLINK, TEXT считаются устаревшими, вместо них предлагается использовать таблицы стилей. Например:

<BODY
                                bgcolor="#FFFFFF"
                                text="#000000"
link="#FF0000"
                                alink="#804000"
vlink="#ff0000">
</BODY>
Вместо этого можно использовать таблицу стилей:
<STYLE type="text/css">
BODY {background: #FFFFFF; color: #000000}
A:link {color: #FF0000}
A:visited {color: #ff0000}
A:active {color: #804000}
</STYLE>
.......
<BODY>
.......
</BODY>
Тэг <Hx> и Тэг <P>
Атрибут ALIGN устарел, и вместо него предлагается использовать таблицу стилей.
<h1 align="center">
<p align="justify">
Вместо этого используем:
<STYLE
                                type="text/css">
h1     {text-align:center}
P      {text-align:justify}
</STYLE>
СПИСКИ
Атрибуты: COMPACT, TYPE, VALUE, START также считаются устаревшими и вместо них предполагается применение таблиц стилей:
<style>
#list1 {list-style-type:square;}
#list2 {list-style-type : upper-alpha;}
#list3 {list-style-type : lower-roman;}
#list4 {list-style-image : url(rigt.gif);}
</style>
.........
<h3> list-style-type : square </h3>
<ul>
<li ID="list1"> Элемент списка 1
<li ID="list1"> Элемент списка 2
</ul>
<h3> list-style-type : upper-alpha </h3>
<ul>
<li ID="list2"> Элемент списка 1
<li ID="list2"> Элемент списка 2
</ul>
<h3> list-style-type : lower-roman </h3>
<ul>
<li ID="list3"> Элемент списка 1
<li ID="list3"> Элемент списка 2
</ul>
<h3> list-style-image : url(rigt.gif)</h3>
<ul>
<li ID="list4"> Элемент списка 1
<li ID="list4"> Элемент списка 2
</ul>

list-style-type : square

  • Элемент списка 1
  • Элемент списка 2

list-style-type : upper-alpha

  • Элемент списка 1
  • Элемент списка 2

list-style-type : lower-roman

  • Элемент списка 1
  • Элемент списка 2

list-style-image : url(rigt.gif)

  • Элемент списка 1
  • Элемент списка 2
Тэги для физического и логического
форматирования текста
Вместо тэгов <U> и <S> предлагается использовать таблицы стилей:
<style>
#uSpan {text-decoration : underline;}
#sSpan {text-decoration : line-through;}
</style>
</head>
.......
<h3> Шрифты </h3>
<p>
<u>Подчеркнутый </u> и <s>Перечеркнутый </s> текст.
</p>
<p> Тот же эффект с помощью таблицы стилей:
<span id="uSpan"> Подчеркнутый </span> и <span id="sSpan"> Перечеркнутый </span> текст.
</p>

Шрифты

Подчеркнутый и Перечеркнутый текст.

Тот же эффект с помощью таблицы стилей:
Подчеркнутый и Перечеркнутый текст.

Элемент <BUTTON>
Этот элемент представляет способ создания кнопок вместо стандартного тэга <INPUT TYPE=BUTTON>. Этот элемент является контейнером и позволяет создавать кнопки с любым содержимым. (к сожалению работает только в IE)Требует закрывающего тэга </BOTTON>:
<button>
такая<BR>
<img src="_picture.gif">
<BR>
Кнопка
</button>

С помощью атрибута NAME можно задать уникальное имя кнопки, атрибут VALUE задает ее значение, атрибут TYPE - тип (BUTTON, RESET, SUBMIT)

Элементы <FIELDSET> и <LEGEND>

Элемент <FIELDSET> используется для объединения нескольких элементов в группу. Заголовок группы задается с помощью элемента <LEGEND>. Например:

<form>
<fieldset>
<legend> Выберите цвет текста: </legend><BR>
<input type=radio value=0>Красный
<input type=radio value=1>Синий
<input type=radio value=2>Зеленый
<input type=radio value=3>Желтый
</fieldset>
</form>
Выберите цвет текста:
Красный Синий Зеленый Желтый

Для управления атрибутами элементов <FIELDSET> и <LEGEND> предлагается использовать таблицы стилей:
<form> fieldset style="background : #5F5F5F; color : #FFFFFF;
width : 400; height : 100;
font-size : 12pt;">
<legend> Выберите цвет текста: </legend><BR>
<input type=radio value=0>Красный
<input type=radio value=1>Синий
<input type=radio value=2>Зеленый
<input type=radio value=3>Желтый
</fieldset>
</form>
Выберите цвет текста:
Красный Синий Зеленый Желтый

Устаревшие тэги в HTML 4.0

Ряд тэгов языка помечены в спецификации как устаревшие, и их использование не рекомендуется для создания новых документов:
APPLET, COMMENT, ISINDEX, PLAINTEXT, U, BASEFONT, DIR, LISTING, S, XMP, CENTER, FONT, MENU, STRIKE

Устаревшими атрибутами считаются:
align, alink, alt, arhive, background, bgcolor, border, clear, code, codebase, color, compact, face, height, hspace, link, name, noshade, nowrap, object, prompt, size, start, text, type, value
Для достижения того же и даже более лучшего результата стандарт HTML 4.0 предлагает использовать возможности таблицы стилей.
Таблица новых тэгов, появившихся в HTML 4.0
Тэг | Краткое описание
ABBR | Указывает на то, что элемент содержит аббревиатуру
BDO | Задает направление отображения текста - слева направо или справа налево
BUTTON | Предоставляет альтернативный способ для создания кнопок
COL | Используется для описания колонок таблицы
COLGROUP | Используется для описания группы колонок
COMMENT | Используется для задания комментариев
DEL | Используется для указания области текста, которая была удалена
FIELDSET | Исп. для объединения нескольких элементов в группу
FRAME | Описывает фрейм в наборе фреймов
FRAMESET | описывает набор фреймов
IFRAME | Описывает "плавающий" фрейм
INS | Исп. для указания области текста, которая была вставлена
LABEL | Задает метку интерфейсного элемента
LEGEND | Задает описание для группы элементов
NOFRAMES | Исп. для браузеров, не поддерживающих фреймы
NOSCRIPT | Исп. для браузеров, не поддерживающих скриптовые языки
OBJECT | Служит для включения в состав страницы различных объектов
Q | Задает краткую цитату
SPAN | Элемент-контейнер в рамках одной строки
TBODY | Задает основное содержание таблицы
TFOOT | Задает нижнюю часть таблицы
THEAD | Задает верхнюю часть таблицы

Стандарт HTML 4.0 является очередным существенным шагом в развитии языка HTML. В заключение можно только отметить, что переход на использование таблицы стилей, что дает, на мой взгляд более гибкое использование элементов форматирования и визуализации будет происходить "со скрипом": во первых, еще много пользователей не расстаются со старыми браузерами; во вторых, трудновато изменять привычкам. Но это мне так казалось 97-98 годах, главное удобство использование CSS заключается в том, что это средство дает более гибкий подход если CSS делать отдельным файлом и загружать в каждую страницу так: <LINK REL=stylesheet HREF="my_set.css">. В данном случае, чтобы изменить какой либо параметр, или, даже полностью вид каждой страницы, достаточно сделать изменения в файле my_set.css.

[<<Назад]

WDstudio © 2000г.