Created using
htm2chm 3.0

Download it NOW!


WDstudio. Все для Веб. Обзоры по Дизайну в Web. В помощь Вебмастеру -->>Зло ли JavaScript?

Клуб друзей

Зло ли JavaScript?

Несколько раз слышал я от профессиональных дизайнеров высказывание: "JavaScript - ЗЛО", так ли это? Попробуем разобраться в чем тут дело. Будем анализировать со стороны разработчиков и со стороны пользователей. Если уж возникло такое мнение, значит имеется перевес "зла" в сторону разработчиков, итак.

В чем зло для разработчиков.

  • Самое первое, заказчик считает, что динамика, всякая анимация и другие "сверкающие" навороты это круто, и именно таким должен быть его сайт. Если дизайнер пытается доказывать, что это дурной стиль, у заказчика складывается мнение, что дизайнер недостаточно опытен. -Это уже больше половины перевеса.

  • Разработчик может проверить правильность введенных форм в некоторых случаях еще до ее отправки. В таком случае неверно заполненная или пустая форма не будет возвращать сообщение об этом средствами CGI или PHP. Здесь теряются возможные баннерные показы.

  • Страница, во многом опирающаяся на средства CSS будет сформатирована неверно, если пользователь отключил поддержку JavaScript, ведь в этом случае отключаются и CSS.

  • При использовании JavaScript некоторые автоперекодировщики например из КОИ8 в 1251 могут поломать текст, тоесть разорвать строку. Браузер в таком случае может выдать сообщение: "Незавершенная строковая константа".

    В чем добро для разработчиков.

  • Пожалуй только в одном: не все заказчики имеют хостинг, или не желают платить с поддержкой CGI, PHP, SSI. Здесь дизайнер может несколько упростить и себе работу, и в случае модификации. А также использовать на стороне клиента некоторое подобие интерактивности. Может "замазать" глаза путем "впаривания" некоторых эффектов DHTML. Также JavaScript самое лучшее средство подстройки под разные версии браузеров, видеорежимов и других мелочей.

    В чем зло для пользователей.

    Ну так, как пользователей очень много, да и все страницы пишутся именно для пользователей, будем говорить подробнее:

  • Первое конечно же ошибки в JavaScript-программах. Типичная ошибка - несовместимость браузеров. Иногда начинающий Web-мастер, так будем называть, просто вставляет готовый скрипт в свои страницы, при этом не разобравшись как это все работает, - результат: "Ошибка сценария", запрос на плагин, или вовсе в Netscape документ не грузится. Также могут и собственные программы нестабильно работать, если разработчик не учел все возможные варианты какого-либо условия, или не проверил работу всех вариантов разветвленной структуры. Неопытный разработчик может не знать о некоторых методах JavaScript, которые применять нежелательно, так как имеются тонкие места в Windows, а именно большинство пользователей используют именно эту ОС, так при использовании "нежелательных" методов может при определенных условиях, например: "не найден URL", просто подвесить компьютер.

  • Второе, представим, что скрипт написан со скрытой "бомбой", которая "бабахнет" например в определенную дату, как это со знаменитым вирусом 26 апреля. Опытный программист может спрятать это очень хорошо путем запутывания кода (переопределение типов, набор строки по символу, деление части "бомбы" по разным функциям, ну и т.д.). Например, я знаю несколько способов как повесить комп пользователя при помощи JavaScript. Так, что это еще и средство злоумышленников. Поэтому некоторые пользователи отключают поддержку JavaScript, при этом лишают себя просмотра страниц форматтированного при помощи CSS, а также DHTML. А если навигация полностью написана на JavaScript, к стати, как на этом сайте, то еще и лишаются навигации. Заверяю, на этом сервере скрипты чистые.

  • Ну и последнее, многим не нравится когда: бегущая строка в статусной строке, вопрос типа "Как ваше имя", Подтверждение ухода по ссылке и другие лишние навороты. Может не понравиться и такой момент, когда пользователь просто хочет посмотреть первую страницу и убедиться: есть ли что для него интересное, а вот разработчик решил, что нужно загрузить весь сайт слоями и быстро показывать нужный при переходе по ссылке, а пользователь ждет лишнюю загрузку. Создание окон с баннерами спонсоров тоже во многом заслуга JavaScript, ну кому это понравится? Лишние двигающиеся, вертящиеся, ползающие, летающие, мигающие, отпрыгивающие, заменяющие, преобразовывающие и другие подобные элементы страницы в некоторой степени украшающие, но часто лишние и мешающие при чрезмерном увлечении ими.

    В чем добро для пользователей.

  • Вообще для чего пишут программы на JavaScript? В основном для привлечения пользователей. Если в меру его использовать, то можно значительно облегчить навигацию пользователю. Также в меру украсить динамическими объектами. Спрятать объекты которые не всем пользователям нужны и показывать по запросу. При отправке формы ее можно сначала проверить на клиентском компьютере, и в случае ошибки вывести предупреждение например с помощью "Alert" - это экономит время пользователя. Вот вроде и все достоинства.

    Что можно сказать в заключение? Нужен ли JavaScript? Действительно ли это зло?
    Пожар это зло? - Да зло. Но без огня мы опустимся до пещерного уровня. Так же и с JavaScript. Если брать во внимание последнюю часть "В чем добро для пользователей" и учитывать отрицательные моменты использования этого языка, - можно сказать: "это мощное средство в Web-дизайне". Нужно только хорошо изучить его, правильно применять и не злоупотреблять.

    [<<Назад] [Вверх]

    • WDstudio © 2001г.