Created using
htm2chm 3.0

Download it NOW!


WMASTER.RU - Всё для web-мастера

www.wmaster.ru
Wmaster.ru

На главную

Введение в дизайн

СТАТЬИ

Хостинг

CODY REG][STER

DOCS

КАТАЛОГ ссылок

Коллекция шрифтов

DESIGN.STudio

Клуб Webмастеров

Рейтинг (top-100)
Скрипты

Секреты мастеров

Soft

Журнал Wmaster

Опросы

Ссылки web-мастеру

Электронные журналы

Обратная связь

Гостевая книга

ФоруМ

web-mastering
Азы языка HTML
Programming
HTML-редакторы
Apache
MySQL
XML
Flash
Photoshop
.htaccess
Всё для форумов
Clipart
3DSMax
SSI
CSS
Технология раскрутки
Авторское право
Кодовые таблицы
Важное

Windows

Links
Woweb.ru - портал для Веб-Мастера
SAD-Raven
NBSP.RU
PHP скрипты
CN-Software
MOROZOV.BIZ
Создание шлейфа мыши
В этом уроке я опишу как создать шлейф, тянущийся за указателем мыши. Наверное Вы уже видели что это такое поэтому давайте сразу передём к созданию.
Создайте новый ролик. В нём создайте символ типа Movie clip с названием “mousepointer”. В этом символе нарисуйте то, что будет являться шлейфом указателя (например стрелочку). В 10 кадре создайте ещё один ключевой кадр. В этом кадре задайте рисунку свойство alpha равное нулю и сделайте анимацию типа Motion tween. У Вас должно получиться что-то вроде этого:
В 10 кадре поставьте такой action:

===========================-
removeMovieClip (_target);
===========================-

Эта строка удаляет объект по окончанию проигрывания.
Теперь создайте ещё один символ – Movie Clip с названием “mt”. В нем создайте два слоя. Первый назовите “actions”, а второй – “mouse”. В слое “mouse” в 1-ом и во 2-ом кадрах создайте пустые ключевые кадры (F7) а в слой “mouse” в первый кадр поместите символ “mousepointer” и задайте ему “mouse” в качестве Instance name , а во второй вставьте обычный кадр (F6). В первый кадр слоя “actions” поместите такой action:

=============================-
i++;
duplicateMovieClip ("mouse", "a"+i, i);
setProperty ("a"+i, _x, _xmouse);
setProperty ("a"+i, _y, _ymouse);
=============================-

Эти строки дублируют “mouse” c новым уникальным именем и глубиной и устанавливают дубликат там же где в данный момент находится указатель мыши. Во втором кадре слоя “actions” напишите:

=================-
gotoAndPlay (1);
=================-
Это нужно для постоянного перехода на 1-ый кадр.
Теперь переходите на главную сцену и создайте там два слоя с именами “act” и “arrows”. В слой “arrows” поместите символ “mt”. А если Вы хотите спрятать оригинальный курсор и нарисовать свой, тогда создайте символ- Movie Clip, нарисуйте там свой курсор и поместите его на главную сцену в слой “arrows”, а чтобы этот курсор заменил обычный, задайте ему “arrow” в качестве Instance name и в первом кадре слоя “act” напишите следующее:

====================-
Mouse.hide();
startDrag ("arrow", true);
====================-

Этот скрипт «спрячет» оригинальный курсор, а на его месте будет красоваться Ваш собственный.
Вот и всё. Теперь можно посмотреть ролик. Если что-то не получилось, проверьте всё ещё раз или сравните Ваше творение с примером.
По вопросам обращаться на Mail или на ICQ.

Mail: jefmk_2000@mail.ru
ICQ: 121863229

*JeF*
Оглавление
Партнеры Wmaster
srez.ru: Новости, уроки DreamWeaver, PhotoShop, HTML
Лучшее веб-мастеру
PIXELATE - Первый в рунете сайт о пиксельной графике! Уроки, галлерея, форум и многое другое!
Поиск по сайту
Объявления
Обмен ссылками
Наши баннеры
О проекте

Реклама
(понижение цен)

Об Авторе
Контакты new!
Архив рассылки
Продажа доменов
Запомнить эту страницу
Сделать стартовой
Хостинг
Хостинг Без Ограничений.
Рассылки от Wmaster.Ru
Wmaster.ru - всё для вебмастера.
Наша кнопка

Все желающие могут поставить нашу кнопочку к себе на сайт
Всё для веб-мастеров

Бочкарёв Антон
ICQ: 148780826
Hosted by Valuehost
© RUscripts.design 2003

© Wmaster Design Group 2001-2003. © Все права защищены. При перепечатке любого материала с сайта ссылка на http://www.wmaster.ru/ обязательна.
Для просмотра рекомендуется разрешение 1024*768, браузер Internet Explorer. Для более эффективного просмотра нажмите F11.